Jump to content

Providing independent coverage of the Minnesota Twins.
Subscribe to Twins Daily Email

The Store

Photo

Odd Session Management Experience

  • Please log in to reply
14 replies to this topic

#1 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 18 September 2012 - 08:02 AM

When I am in the forum and logged in, if, from a forum post, I click a link to an article on the home page, I will not be logged in there. Then, if I try to navigate back to the forum, from the front page, I will no longer be logged in there.

On the other hand, if I go to the home page directly by typing twinsdaily.com into the address bar, I will be logged in again, even after having just been there not logged in. The same thing happens if I go back to the forum by typing the address... I am already logged in.

I have experienced this several times. Does anyone else have this problem?

#2 Brock Beauchamp

Brock Beauchamp

    Owner

  • Administrators
  • 8,447 posts

Posted 18 September 2012 - 10:44 AM

That's interesting. Firing off the cuff, it makes me think that it has something to do with cloud password storage. Most browsers offer this (it saves your passwords on any computer you are logged into)... The reason I'd guess that's the case is because if you go to the front page, it logs you in but fails to do it in other pages.

What browser and version are you using?

Also, I would try clearing your browsing history, cache, cookies, etc.

#3 Shane Wahl

Shane Wahl

    Senior Member

  • Members
  • 4,016 posts

Posted 18 September 2012 - 11:08 AM

I have had this happen recently some as well, on my office computer (using Firefox).

#4 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 18 September 2012 - 01:20 PM

I am using FF too. I cleared history and cookies, closed and re-opened FF. I logged in to TD. I went to the Twins Talk forum, viewed Seth's post of his article The Final Fifteen; What to Watch For, clicked the link to his article and the same thing happened. I was redirected to his article but I was not logged in on that page.

#5 DAM DC Twins Fans

DAM DC Twins Fans

    Senior Member

  • Members
  • 476 posts

Posted 18 September 2012 - 01:37 PM

I am using IE as my browser. Sometimes when I click on this site--I am logged in. Sometimes not. Just now, I had to relog in and clicked remember me. We will see if that works. Earlier I was viewing the article about shutting down Diamond, got redirected somewhere (not sure) and while moving heard an Obama ad (I may have fat fingered but I didnt do anything intentionally). I didnt click on ad which I dont want and was not trying to go anywhere.

I like the site--especially the articles by Seth and Nick and JC and the comments (when they are not nasty). But it is DAM frustrating. Way too many ads (I know you guys want $$) and way too long to load. If the frustration stays I will go. How about reducing the ads per page??

#6 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 18 September 2012 - 01:38 PM

OK, I just went through the same process with John Bonnes' post Does A Deal With Scott Baker Make Sense? and, when I was redirected, I was logged in. I went back and tried it with Seth's article and I was not logged in.

#7 Brock Beauchamp

Brock Beauchamp

    Owner

  • Administrators
  • 8,447 posts

Posted 18 September 2012 - 02:04 PM

Could I get your version of FF? I'll check into it and see if I can find the source of the problem.

#8 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 18 September 2012 - 02:12 PM

15.0.1

#9 Brock Beauchamp

Brock Beauchamp

    Owner

  • Administrators
  • 8,447 posts

Posted 18 September 2012 - 02:32 PM

Hmmm. The first thing I found was "remove the offending cookie". You can follow directions for it here:

http://support.mozil...uestions/936628

I'll keep looking.

#10 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 18 September 2012 - 02:40 PM

I did a little testing. I went through all posts of "articles". I have listed the results below. It looks to me like posts by yourself, John Bonnes and Parker Hageman result in my still being logged in. Posts by Seth Stohs, Cody Christie and Nick Nelson result in my not being logged in. Could it be a setting with the articles or hyperlinks or method of posting?

No Seth Stohs The Final Fifteen...
Yes John Bonnes Does A Deal With Scott...
No Cody Christie Should Scott Diamond...
Yes John Bonnes Gleeman and the Geek...
No Cody Christie Pedro Floriman in Line...
No Nick Nelson SP Depth Chart...
Yes Parker Hageman What's Hindering Hendriks?
Yes Brock Beauchamp Minnesota Twins Roster...
No Shane Wahl Yes, The Twins Have...
No Cody Christie Friday Links-N-Thinks
Yes Parker Hageman Mauer sidelined with...
No Nick Nelson Orioles Provide Hope...
No Seth Stohs Comparing Strasburg...
No Nick Nelson In Perk We Trust
Yes John Bonnes Justin Morneau Reminds...
No Cody Christie Cole De Vries making...
Yes John Bonnes Gleeman and the Geek...
Yes Parker Hageman Twins drop series...
No Cody Christie The Curious Case of...

#11 Brock Beauchamp

Brock Beauchamp

    Owner

  • Administrators
  • 8,447 posts

Posted 18 September 2012 - 03:14 PM

Unlikely. It's possible, but really unlikely for a variety of reasons. I'll do more research into it and see what I can figure out.

#12 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 22 September 2012 - 09:54 AM

I don't want to make too much of this. It is only a minor annoyance. However, I looked at articles posted since I posted the earlier data. The delineation by article author appears to continue.

[TABLE]
[TR]
[TD]Writer[/TD]
[TD="width: 96, align: center"]Not Logged In
[/TD]
[TD="width: 86, align: center"]Logged In[/TD]
[/TR]
[TR]
[TD]Seth Stohs[/TD]
[TD="align: center"]7[/TD]
[TD="align: center"]0[/TD]
[/TR]
[TR]
[TD]Cody Christie[/TD]
[TD="align: center"]7[/TD]
[TD="align: center"]0[/TD]
[/TR]
[TR]
[TD]Nick Nelson[/TD]
[TD="align: center"]4[/TD]
[TD="align: center"]0[/TD]
[/TR]
[TR]
[TD]Shane Wahl[/TD]
[TD="align: center"]1[/TD]
[TD="align: center"]0[/TD]
[/TR]
[TR]
[TD]AJPetterson[/TD]
[TD="align: center"]1[/TD]
[TD="align: center"]0[/TD]
[/TR]
[TR]
[TD]John Bonnes[/TD]
[TD="align: center"]0[/TD]
[TD="align: center"]5[/TD]
[/TR]
[TR]
[TD]Parker Hageman[/TD]
[TD="align: center"]0[/TD]
[TD="align: center"]4
[/TD]
[/TR]
[TR]
[TD]Jim Crikket[/TD]
[TD="align: center"]0[/TD]
[TD="align: center"]1[/TD]
[/TR]
[TR]
[TD]Brock Beauchamp[/TD]
[TD="align: center"]0[/TD]
[TD="align: center"]1[/TD]
[/TR]
[/TABLE]

#13 Brock Beauchamp

Brock Beauchamp

    Owner

  • Administrators
  • 8,447 posts

Posted 22 September 2012 - 10:52 AM

Sorry, I had forgotten about this... I've been stupid-busy this week. I looked more into it and found a cookie setting that *may* have been causing the problem in some browsers. Double check and see if it has been fixed for you.

#14 Curt

Curt

    Senior Member

  • Members
  • 240 posts

Posted 22 September 2012 - 12:47 PM

I had tried that earlier but I skipped one part in that tutorial: I never set "Accept third-party cookies." So I tried it this time and that did the trick.

Then, once that worked, I turned third-party cookies off again, deleted all cookies, cleared cache, restarted FF, logged into TD, clicked the "offending" hyperlinks and I was still logged in.

So, my take on what happened is TD has a third-party cookie that needs to be set. Once the cookie is in place, login persistence is maintained when the hyperlinks are clicked. I have FF set to "Opt Out" of tracking so when the third party cookie was set, it was set to opt out. Opt out cookies do not delete. So, even though I deleted cookies and turned off third-party cookies, the cookie is still set and the hyperlink click maintains the login credential.

Thanks for your efforts.

#15 Brock Beauchamp

Brock Beauchamp

    Owner

  • Administrators
  • 8,447 posts

Posted 22 September 2012 - 08:23 PM

What I did this afternoon is change the automatic cookie setting for Twins Daily. There may have been a problem with FireFox differentiating between two different sites... www.TwinsDaily.com and TwinsDaily.com. It's a stupid problem that FF shouldn't be having at this point in its life but whatever... I changed TD's cookies so that it will appear as .TwinsDaily.com every time. I think that should resolve your problem.